High, CVSS 7.5MavenPublished
Apache James vulnerable to denial of service through JMAP HTML to text conversion
CVE-2024-45626 · GHSA-57m2-h3fw-rxhw
- Affected
- Maven org.apache.james:james-server-jmap-draft >= 3.8.0, < 3.8.2; < 3.7.6
- Fixed in
- 3.7.63.8.2· Vendor fix available
- Issue
- Apache James server JMAP HTML to text plain implementation in versions below 3.8.2 and 3.7.6 is subject to unbounded memory consumption that can result in a denial of service. Users are recommended to upgrade to version 3.7.6 and 3.8.2, which fix this issue.
Recommended action: Upgrade to 3.8.2 or 3.7.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.