High, CVSS 8.8MavenPublished
Apache Jackrabbit Authentication Hijacking Vulnerability
CVE-2016-6801 · GHSA-9fc7-rhq3-wm7x
- Affected
- Maven org.apache.jackrabbit:jackrabbit-webdav >= 2.4.0, < 2.4.6; >= 2.6.0, < 2.6.6; >= 2.8.0, < 2.8.3; >= 2.10.0, < 2.10.4; >= 2.12.0, < 2.12.4; >= 2.13.0, < 2.13.3
- Fixed in
- 2.12.42.10.42.8.32.6.62.13.32.4.6· Vendor fix available
- Issue
- Cross-site request forgery (CSRF) vulnerability in the CSRF content-type check in Jackrabbit-Webdav in Apache Jackrabbit 2.4.x before 2.4.6, 2.6.x before 2.6.6, 2.8.x before 2.8.3, 2.10.x before 2.10.4, 2.12.x before 2.12.4, and 2.13.x before 2.13.3 allows remote attackers to hijack the authentication of unspecified victims for requests that create a resource via an HTTP POST request with a (1) missing or (2) crafted Content-Type header.
Recommended action: Upgrade to 2.13.3, 2.12.4, 2.10.4 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.