Skip to content

← Public intelligence

Maven package

org.apache.jackrabbit:jackrabbit-jcr-commons

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Apache Jackrabbit: Core and JCR Commons are vulnerable to Deserialization of Untrusted Data

    CVE-2025-58782 · GHSA-cxvc-g8f2-4gmm

    Affected
    • Maven org.apache.jackrabbit:jackrabbit-jcr-commons >= 1.0.0, < 2.22.2
    Fixed in
    2.22.2· Vendor fix available
    Issue
    There is a serialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons. This issue affects Apache Jackrabbit Core: from 1.0.0 through 2.22.1; Apache Jackrabbit JCR Commons: from 1.0.0 through 2.22.1. Deployments that accept JNDI URIs for JCR lookup from untrusted users allows them to inject malicious JNDI references, potentially leading to arbitrary code execution through deserialization of untrusted data. Users are recommended to upgrade to version 2.22.2. JCR lookup through JNDI has been disabled by default in 2.22.2. Users of this feature need to enable it explicitly and are adviced to review their use of JNDI URI for JCR lookup.

    Recommended action: Upgrade to 2.22.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →