High, CVSS 7.2MavenPublished
Apache Inlong Code Injection vulnerability
CVE-2024-36268 · GHSA-qff2-8qw7-hcvw
- Affected
- Maven org.apache.inlong:tubemq-core >= 1.10.0, < 1.13.0
- Fixed in
- 1.13.0· Vendor fix available
- Issue
- Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong. This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/10251
Recommended action: Upgrade to 1.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.