Skip to content

← Public intelligence

Maven package

org.apache.inlong:manager-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3MavenPublished

    Apache InLong: Logged-in user could exploit an arbitrary file read vulnerability

    CVE-2024-26580 · GHSA-p2gx-4434-pf6g

    Affected
    • Maven org.apache.inlong:manager-common >= 1.8.0, < 1.11.0
    Fixed in
    1.11.0· Vendor fix available
    Issue
    Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9673

    Recommended action: Upgrade to 1.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Apache InLong Deserialization of Untrusted Data Vulnerability

    CVE-2023-46227 · GHSA-jj32-3pf5-5mv5

    Affected
    • Maven org.apache.inlong:manager-common >= 1.4.0, < 1.9.0
    Fixed in
    1.9.0· Vendor fix available
    Issue
    Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong: from 1.4.0 through 1.8.0, the attacker can use \t to bypass. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8814

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Apache InLong Deserialization of Untrusted Data Vulnerability

    CVE-2023-31058 · GHSA-c3rh-f2w5-fghm

    Affected
    • Maven org.apache.inlong:manager-common >= 1.4.0, < 1.7.0
    Fixed in
    1.7.0· Vendor fix available
    Issue
    Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. Attackers would bypass the autoDeserialize option filtering by adding blanks. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7674 to solve it.

    Recommended action: Upgrade to 1.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →