Skip to content

← Public intelligence

Maven package

org.apache.inlong:inlong-manager

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Apache InLong Deserialization of Untrusted Data Vulnerability

    CVE-2025-27531 · GHSA-62gc-8jr5-x9pm

    Affected
    • Maven org.apache.inlong:inlong-manager >= 1.13.0, < 2.1.0
    Fixed in
    2.1.0· Vendor fix available
    Issue
    Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 before 2.1.0, this issue would allow an authenticated attacker to read arbitrary files by double writing the param. Users are recommended to upgrade to version 2.1.0, which fixes the issue.

    Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Apache InLong: General user can delete and update process

    CVE-2023-34189 · GHSA-86pw-4rqp-6x7v

    Affected
    • Maven org.apache.inlong:inlong-manager >= 1.4.0, < 1.8.0
    Fixed in
    1.8.0· Vendor fix available
    Issue
    Exposure of Resource to Wrong Sphere Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.7.0. The attacker could use general users to delete and update the process, which only the admin can operate occurrences. Users are advised to upgrade to Apache InLong's 1.8.0 or cherry-pick https://github.com/apache/inlong/pull/8109 to solve it.

    Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Apache InLong vulnerable to JDBC Deserialization of Untrusted Data

    CVE-2023-27296 · GHSA-gpqq-59rp-3c3w

    Affected
    • Maven org.apache.inlong:inlong-manager >= 1.1.0, < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    Apache InLong versions from 1.1.0 through 1.5.0 are vulnerable to Java Database Connectivity (JDBC) deserialization of untrusted data from the MySQL JDBC URL in MySQLDataNode. It could be triggered by authenticated users of InLong. This has been patched in version 1.6.0. Users are advised to upgrade to Apache InLong's latest version or cherry-pick the patch to solve it.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →