Skip to content

← Public intelligence

Maven package

org.apache.ignite:ignite-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.5MavenPublished

    Apache Ignite REST API Has a Relative Path Traversal Vulnerability

    CVE-2025-48977 · GHSA-v45h-mqf4-6939

    Affected
    • Maven org.apache.ignite:ignite-core >= 2.0.0, < 2.18.0
    Fixed in
    2.18.0· Vendor fix available
    Issue
    Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.

    Recommended action: Upgrade to 2.18.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.5MavenPublished

    Apache Ignite: Possible RCE when deserializing incoming messages by the server node

    CVE-2024-52577 · GHSA-8355-xj3p-hv6q

    Affected
    • Maven org.apache.ignite:ignite-core >= 2.6.0, < 2.17.0
    Fixed in
    2.17.0· Vendor fix available
    Issue
    In Apache Ignite versions from 2.6.0 and before 2.17.0, configured Class Serialization Filters are ignored for some Ignite endpoints. The vulnerability could be exploited if an attacker manually crafts an Ignite message containing a vulnerable object whose class is present in the Ignite server classpath and sends it to Ignite server endpoints. Deserialization of such a message by the Ignite server may result in the execution of arbitrary code on the Apache Ignite server side.

    Recommended action: Upgrade to 2.17.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.1MavenPublished

    File system access via H2 in Apache Ignite

    CVE-2020-1963 · GHSA-5wm5-8q42-rhxg

    Affected
    • Maven org.apache.ignite:ignite-core < 2.8.1
    Fixed in
    2.8.1· Vendor fix available
    Issue
    Apache Ignite uses H2 database to build SQL distributed execution engine. H2 provides SQL functions which could be used by attacker to access to a filesystem.

    Recommended action: Upgrade to 2.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8MavenPublished

    Code execution via deserialization in org.apache.ignite:ignite-core

    CVE-2018-8018 · GHSA-qcjv-wfcg-mmpr

    Affected
    • Maven org.apache.ignite:ignite-core < 2.6
    Fixed in
    2.6· Vendor fix available
    Issue
    Apache Ignite 2.5 and earlier serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to GridClientJdkMarshaller deserialization endpoint.

    Recommended action: Upgrade to 2.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.8MavenPublished

    Apache serialization mechanism does not have a list of classes allowed for serialization/deserialization

    CVE-2018-1295 · GHSA-chp4-rv79-68j3

    Affected
    • Maven org.apache.ignite:ignite-core < 2.4
    Fixed in
    2.4· Vendor fix available
    Issue
    In Apache Ignite 2.3 or earlier, the serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to one of the deserialization endpoints of some Ignite components - discovery SPI, Ignite persistence, Memcached endpoint, socket steamer.

    Recommended action: Upgrade to 2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.9MavenPublished

    Moderate severity vulnerability that affects org.apache.ignite:ignite-core

    CVE-2016-6805 · GHSA-8qfc-cvjp-mgpq

    Affected
    • Maven org.apache.ignite:ignite-core < 1.9
    Fixed in
    1.9· Vendor fix available
    Issue
    Apache Ignite before 1.9 allows man-in-the-middle attackers to read arbitrary files via XXE in modified update-notifier documents.

    Recommended action: Upgrade to 1.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 7.5MavenPublished

    Apache Ignite communicates to an external PHP server where sensitive information is sent

    CVE-2017-7686 · GHSA-8p83-68cw-943f

    Affected
    • Maven org.apache.ignite:ignite-core < 2.1
    Fixed in
    2.1· Vendor fix available
    Issue
    Apache Ignite 1.0.0-RC3 to 2.0 uses an update notifier component to update the users about new project releases that include additional functionality, bug fixes and performance improvements. To do that the component communicates to an external PHP server (http://ignite.run) where it needs to send some system properties like Apache Ignite or Java version. Some of the properties might contain user sensitive information.

    Recommended action: Upgrade to 2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →