Skip to content

← Public intelligence

Maven package

org.apache.hbase:hbase

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Improper Authorization in org.apache.hbase:hbase

    CVE-2019-0212 · GHSA-535v-4x9q-446c

    Affected
    • Maven org.apache.hbase:hbase >= 2.0.0, < 2.0.5; >= 2.1.0, < 2.1.4
    Fixed in
    2.0.52.1.4· Vendor fix available
    Issue
    In all previously released Apache HBase 2.x versions (2.0.0-2.0.4, 2.1.0-2.1.3), authorization was incorrectly applied to users of the HBase REST server. Requests sent to the HBase REST server were executed with the permissions of the REST server itself, not with the permissions of the end-user. This issue is only relevant when HBase is configured with Kerberos authentication, HBase authorization is enabled, and the REST server is configured with SPNEGO authentication. This issue does not extend beyond the HBase REST server.

    Recommended action: Upgrade to 2.1.4 or 2.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.3MavenPublished

    High severity vulnerability that affects org.apache.hbase:hbase

    CVE-2015-1836 · GHSA-p8xr-4v2c-rvgp

    Affected
    • Maven org.apache.hbase:hbase >= 1.1.0, <= 1.1.0; >= 0.98, <= 0.98.12.0; >= 1.0.0, <= 1.0.1.0
    Fixed in
    1.0.1.10.98.12.11.1.0.1· Vendor fix available
    Issue
    Apache HBase 0.98 before 0.98.12.1, 1.0 before 1.0.1.1, and 1.1 before 1.1.0.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, uses incorrect ACLs for ZooKeeper coordination state, which allows remote attackers to cause a denial of service (daemon outage), obtain sensitive information, or modify data via unspecified client traffic.

    Recommended action: Upgrade to 1.1.0.1, 1.0.1.1 or 0.98.12.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →