Critical, CVSS 9.8MavenPublished
Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop
CVE-2016-3086 · GHSA-895m-ww55-59vw
- Affected
- Maven org.apache.hadoop:hadoop-yarn-server-nodemanager >= 2.6.0, <= 2.6.4; >= 2.7.0, <= 2.7.2
- Fixed in
- 2.7.32.6.5· Vendor fix available
- Issue
- The YARN NodeManager in Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3 can leak the password for credential store provider used by the NodeManager to YARN Applications.
Recommended action: Upgrade to 2.7.3 or 2.6.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.