High, CVSS 8.8MavenPublished
User account escalation in Apache Hadoop
CVE-2021-33036 · GHSA-58jx-f5rf-qgqf
- Affected
- Maven org.apache.hadoop:hadoop-yarn-server-common >= 2.2.0, < 2.10.2; >= 3.0.0, < 3.2.3; >= 3.3.0, < 3.3.2
- Fixed in
- 2.10.23.2.33.3.2· Vendor fix available
- Issue
- In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Recommended action: Upgrade to 3.3.2, 3.2.3 or 2.10.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.