Skip to content

← Public intelligence

Maven package

org.apache.hadoop:hadoop-yarn-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Deserialization of Untrusted Data in Apache Hadoop YARN

    CVE-2021-25642 · GHSA-rr2m-gffv-mgrj

    Affected
    • Maven org.apache.hadoop:hadoop-yarn-server < 2.10.2; >= 3.0.0, < 3.2.4; >= 3.3.0, < 3.3.4
    Fixed in
    2.10.23.2.43.3.4· Vendor fix available
    Issue
    ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.

    Recommended action: Upgrade to 3.3.4, 3.2.4 or 2.10.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →