High, CVSS 7.3MavenPublished
Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability
CVE-2025-27821 · GHSA-92cc-952p-v8rh
- Affected
- Maven org.apache.hadoop:hadoop-hdfs-native-client >= 3.2.0, < 3.4.2
- Fixed in
- 3.4.2· Vendor fix available
- Issue
- Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Recommended action: Upgrade to 3.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.