Medium, CVSS 6.1MavenPublished
Apache Geode web-api is vulnerable to Cross-site Scripting
CVE-2024-44088 · GHSA-w595-4975-gm3h
- Affected
- Maven org.apache.geode:geode-web-api >= 1.1.0, < 1.15.2
- Fixed in
- 1.15.2· Vendor fix available
- Issue
- Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2. Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Recommended action: Upgrade to 1.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.