High, CVSS 8.8MavenPublished
Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system
CVE-2025-47410 · GHSA-gjp8-99fv-cgcw
- Affected
- Maven org.apache.geode:geode-web >= 1.10.0, < 1.15.2
- Fixed in
- 1.15.2· Vendor fix available
- Issue
- Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Recommended action: Upgrade to 1.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.