Skip to content

← Public intelligence

Maven package

org.apache.felix:org.apache.felix.webconsole

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Apache Felix Webconsole: XSS in services console

    CVE-2025-25247 · GHSA-4c37-7m5h-c8m9

    Affected
    • Maven org.apache.felix:org.apache.felix.webconsole >= 4.0.0, < 4.9.10; >= 5.0.0, < 5.0.10
    Fixed in
    5.0.104.9.10· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

    Recommended action: Upgrade to 5.0.10 or 4.9.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →