Medium, CVSS 6.3MavenPublished
Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin
CVE-2025-27867 · GHSA-2cv6-4f2r-jq2c
- Affected
- Maven org.apache.felix:org.apache.felix.http.webconsoleplugin < 1.2.2
- Fixed in
- 1.2.2· Vendor fix available
- Issue
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Recommended action: Upgrade to 1.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.