Medium, CVSS 6.1MavenPublished
Cross-site Scripting in healthcheck webconsole plugin
CVE-2023-38435 · GHSA-4pvw-g9fx-594r
- Affected
- Maven org.apache.felix:org.apache.felix.healthcheck.webconsoleplugin < 2.1.0
- Fixed in
- 2.1.0· Vendor fix available
- Issue
- An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Apache Felix Healthcheck Webconsole Plugin version 2.0.2 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack. Upgrade to Apache Felix Healthcheck Webconsole Plugin 2.1.0 or higher.
Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.