Skip to content

← Public intelligence

Maven package

org.apache.eventmesh:eventmesh-meta-raft

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache EventMesh: raft Hessian Deserialization Vulnerability allowing remote code execution

    CVE-2024-56180 · GHSA-ffvr-gmp3-xx43

    Affected
    • Maven org.apache.eventmesh:eventmesh-meta-raft >= 1.10.1, < 1.11.0
    Fixed in
    1.11.0· Vendor fix available
    Issue
    CWE-502 Deserialization of Untrusted Data at the eventmesh-meta-raft plugin module in Apache EventMesh master branch without release version on windows\linux\mac os e.g. platforms allows attackers to send controlled message and remote code execute via hessian deserialization rpc protocol. Users can use the code under the master branch in project repo or version 1.11.0 to fix this issue.

    Recommended action: Upgrade to 1.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →