Skip to content

← Public intelligence

Maven package

org.apache.drill:drill-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Apache Drill vulnerable to Cross-site Scripting

    CVE-2017-12630 · GHSA-xp4g-5xj6-6vpr

    Affected
    • Maven org.apache.drill:drill-common < 1.12.0
    Fixed in
    1.12.0· Vendor fix available
    Issue
    In Apache Drill 1.11.0 and earlier, when submitting form from Query page, users are able to pass arbitrary script or HTML which will take effect on Profile page afterwards. Example: after submitting special script that returns cookie information from Query page, malicious user may obtain this information from Profile page afterwards.

    Recommended action: Upgrade to 1.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →