Critical, CVSS 9.3MavenPublished
Apache Dolphinscheduler Code Injection vulnerability
CVE-2024-43202 · GHSA-2fm6-mv57-p2qh
- Affected
- Maven org.apache.dolphinscheduler:dolphinscheduler-task-api >= 3.1.0, < 3.2.2
- Fixed in
- 3.2.2· Vendor fix available
- Issue
- Exposure of Remote Code Execution in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.2. We recommend users to upgrade Apache DolphinScheduler to version 3.2.2, which fixes the issue.
Recommended action: Upgrade to 3.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.