Skip to content

← Public intelligence

Maven package

org.apache.dolphinscheduler:dolphinscheduler-master

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenPublished

    Apache DolphinScheduler vulnerable to arbitrary JavaScript execution as root for authenticated users

    CVE-2024-23320 · GHSA-rc6h-qwj9-2c53

    Affected
    • Maven org.apache.dolphinscheduler:dolphinscheduler-master < 3.2.1
    Fixed in
    3.2.1· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed JavaScript to be executed on the server. This issue is a legacy of CVE-2023-49299. We didn't fix it completely in CVE-2023-49299, and we added one more patch to fix it. This issue affects Apache DolphinScheduler: until 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue.

    Recommended action: Upgrade to 3.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.7MavenPublished

    Apache DolphinScheduler: Arbitrary js execute as root for authenticated users

    CVE-2023-49299 · GHSA-v7hg-77v9-2445

    Affected
    • Maven org.apache.dolphinscheduler:dolphinscheduler-master < 3.1.9
    Fixed in
    3.1.9· Vendor fix available
    Issue
    Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9. Users are recommended to upgrade to version 3.1.9, which fixes the issue.

    Recommended action: Upgrade to 3.1.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →