Medium, CVSS 6.1MavenPublished
Cross-site Scripting in Apache DeltaSpike
CVE-2017-17837 · GHSA-4q23-g7mf-xp98
- Affected
- Maven org.apache.deltaspike.modules:jsf-module-project < 1.8.1
- Fixed in
- 1.8.1· Vendor fix available
- Issue
- The Apache DeltaSpike-JSF 1.8.0 module has a XSS injection leak in the windowId handling. The default size of the windowId get's cut off after 10 characters (by default), so the impact might be limited. A fix got applied and released in Apache deltaspike-1.8.1.
Recommended action: Upgrade to 1.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.