Critical, CVSS 9.8MavenPublished
Apache CXF has an LDAP injection vulnerability
CVE-2026-44930 · GHSA-pg32-686q-qh6x
- Affected
- Maven org.apache.cxf.services.xkms:cxf-services-xkms-x509-repo-ldap >= 4.2.0, <= 4.2.0; >= 4.1.0, < 4.1.6; < 3.6.11
- Fixed in
- 4.2.13.6.114.1.6· Vendor fix available
- Issue
- An LDAP injection vulnerability in the LDAP Certificate repository of the XKMS server in Apache CXF may allow an attacker to retrieve arbitrary certificates from the repository. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.
Recommended action: Upgrade to 4.2.1, 4.1.6 or 3.6.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.