Skip to content

← Public intelligence

Maven package

org.apache.cxf.fediz:fediz-spring

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3

    CVE-2017-12631 · GHSA-fv7x-4hpc-hf9f

    Affected
    • Maven org.apache.cxf.fediz:fediz-spring < 1.3.3; >= 1.4.0, < 1.4.3
    Fixed in
    1.3.31.4.3· Vendor fix available
    Issue
    Apache CXF Fediz ships with a number of container-specific plugins to enable WS-Federation for applications. A CSRF (Cross Style Request Forgery) style vulnerability has been found in the Spring 2, Spring 3 and Spring 4 plugins in versions before 1.4.3 and 1.3.3. The vulnerability can result in a security context that is set up using a malicious client's roles for the given enduser.

    Recommended action: Upgrade to 1.4.3 or 1.3.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2

    CVE-2016-4464 · GHSA-qpwj-mvv7-v3m9

    Affected
    • Maven org.apache.cxf.fediz:fediz-spring >= 1.2.0, < 1.2.3; >= 1.3.0, <= 1.3.0
    Fixed in
    1.2.31.3.1· Vendor fix available
    Issue
    The application plugins in Apache CXF Fediz 1.2.x before 1.2.3 and 1.3.x before 1.3.1 do not match SAML AudienceRestriction values against configured audience URIs, which might allow remote attackers to have bypass intended restrictions and have unspecified other impact via a crafted SAML token with a trusted signature.

    Recommended action: Upgrade to 1.3.1 or 1.2.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and…

    CVE-2018-8038 · GHSA-w3gh-g32m-cvhr

    Affected
    • Maven org.apache.cxf.fediz:fediz-spring < 1.4.4
    Fixed in
    1.4.4· Vendor fix available
    Issue
    Versions of Apache CXF Fediz prior to 1.4.4 do not fully disable Document Type Declarations (DTDs) when either parsing the Identity Provider response in the application plugins, or in the Identity Provider itself when parsing certain XML-based parameters.

    Recommended action: Upgrade to 1.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →