Skip to content

← Public intelligence

Maven package

org.apache.cxf:cxf-rt-transports-jms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache CXF has JNDI Injection Vulnerability in JMSConfigFactory

    CVE-2026-50632 · GHSA-93g8-qqv3-mrx8

    Affected
    • Maven org.apache.cxf:cxf-rt-transports-jms >= 4.2.0, < 4.2.2; >= 4.1.0, < 4.1.7; < 3.6.12
    Fixed in
    3.6.124.2.24.1.7· Vendor fix available
    Issue
    A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

    Recommended action: Upgrade to 4.2.2, 4.1.7 or 3.6.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Apache CXF: Untrusted JMS configuration can lead to RCE

    CVE-2026-44417 · GHSA-2hvc-5c6v-f533

    Affected
    • Maven org.apache.cxf:cxf-rt-transports-jms >= 4.2.0, <= 4.2.0; >= 4.1.0, < 4.1.6; < 3.6.11
    Fixed in
    4.2.13.6.114.1.6· Vendor fix available
    Issue
    The fix for CVE-2025-48913: Apache CXF: Untrusted JMS configuration can lead to RCE was not complete, meaning that another path in the code might lead to code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.

    Recommended action: Upgrade to 4.2.1, 4.1.6 or 3.6.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.3MavenPublished

    Apache CXF: Untrusted JMS configuration can lead to RCE

    CVE-2025-48913 · GHSA-g4px-6qhm-hqjm

    Affected
    • Maven org.apache.cxf:cxf-rt-transports-jms < 3.6.8; >= 4.0.0, < 4.0.9; >= 4.1.0, < 4.1.3
    Fixed in
    4.1.33.6.84.0.9· Vendor fix available
    Issue
    If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility. Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.

    Recommended action: Upgrade to 4.1.3, 4.0.9 or 3.6.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →