High, CVSS 8.2MavenPublished
Apache CXF: SSRF vulnerability via WADL stylesheet parameter
CVE-2024-29736 · GHSA-5m3j-pxh7-455p
- Affected
- Maven org.apache.cxf:cxf-rt-rs-service-description >= 4.0.0, < 4.0.5; >= 3.6.0, < 3.6.4; < 3.5.9
- Fixed in
- 3.6.43.5.94.0.5· Vendor fix available
- Issue
- A SSRF vulnerability in WADL service description in versions of Apache CXF before 4.0.5, 3.6.4 and 3.5.9 allows an attacker to perform SSRF style attacks on REST webservices. The attack only applies if a custom stylesheet parameter is configured.
Recommended action: Upgrade to 4.0.5, 3.6.4 or 3.5.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.