Medium, CVSS 6.9MavenPublished
Apache CXF Denial of Service vulnerability in JOSE
CVE-2024-32007 · GHSA-6pff-fmh2-4mmf
- Affected
- Maven org.apache.cxf:cxf-rt-rs-security-jose >= 4.0.0, < 4.0.5; >= 3.6.0, < 3.6.4; < 3.5.9
- Fixed in
- 3.6.43.5.94.0.5· Vendor fix available
- Issue
- An improper input validation of the p2c parameter in the Apache CXF JOSE code before 4.0.5, 3.6.4 and 3.5.9 allows an attacker to perform a denial of service attack by specifying a large value for this parameter in a token.
Recommended action: Upgrade to 4.0.5, 3.6.4 or 3.5.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.