Critical, CVSS 9.8MavenPublished
Apache CXF JNDI Injection vulnerability in DispatchMDBMessageListenerImpl
CVE-2026-50633 · GHSA-qp3f-rvj8-46c8
- Affected
- Maven org.apache.cxf:cxf-integration-jca >= 4.2.0, < 4.2.2; < 4.1.7
- Fixed in
- 4.2.24.1.7· Vendor fix available
- Issue
- A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7, which fixes this issue.
Recommended action: Upgrade to 4.2.2 or 4.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.