High, CVSS 8.8MavenPublished
Apache Commons Improper Access Control vulnerability
CVE-2025-48734 · GHSA-wxr5-93ph-8wr9
- Affected
- Maven org.apache.commons:commons-beanutils2 >= 2.0.0-M1, < 2.0.0-M2
- Fixed in
- 2.0.0-M2· Vendor fix available
- Issue
- Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default. PropertyUtilsBean (and consequently BeanUtilsBean) now disallows declared class level property access by default. Releases 1.11.0 and 2.0.0-M2 address a potential security issue when accessing enum properties in an uncontrolled way. If an application using Commons BeanUtils passes property paths from an external source directly to the getProperty() method of PropertyUtilsBean, an attacker can access the enum’s class loader via the “declaredClass” property available on all Java “enum” objects. Accessing the enum’s “declaredClass” allows remote attackers to access the ClassLoader and execute arbitrary code. The same issue exists with PropertyUtilsBean.getNestedProperty(). Starting in versions…
Recommended action: Upgrade to 2.0.0-M2 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.