Skip to content

← Public intelligence

Maven package

org.apache.cocoon:cocoon

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Apache Cocoon Improper Restriction of XML External Entity Reference vulnerability

    CVE-2023-49733 · GHSA-77jg-cpw9-73vg

    Affected
    • Maven org.apache.cocoon:cocoon >= 2.2.0, < 2.3.0
    Fixed in
    2.3.0· Vendor fix available
    Issue
    Improper Restriction of XML External Entity Reference vulnerability in Apache Cocoon. This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.

    Recommended action: Upgrade to 2.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Apache Cocoon SQL Injection vulnerability

    CVE-2022-45135 · GHSA-8v4w-jr33-4rh3

    Affected
    • Maven org.apache.cocoon:cocoon >= 2.2.0, < 2.3.0
    Fixed in
    2.3.0· Vendor fix available
    Issue
    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Cocoon. This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.

    Recommended action: Upgrade to 2.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →