Critical, CVSS 9.8MavenPublished
Camel-xstream component in Apache Camel can allow remote attackers to execute arbitrary commands
CVE-2015-5344 · GHSA-gv5f-cjw9-5vxg
- Affected
- Maven org.apache.camel:camel-xstream < 2.15.5; >= 2.16.0, <= 2.16.0
- Fixed in
- 2.15.52.16.1· Vendor fix available
- Issue
- The camel-xstream component in Apache Camel before 2.15.5 and 2.16.x before 2.16.1 allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.
Recommended action: Upgrade to 2.16.1 or 2.15.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.