Critical, CVSS 9.8MavenPublished
Apache Camel's camel-snakeyaml component is vulnerable to Java object de-serialization
CVE-2017-3159 · GHSA-hvpr-9cr6-q5v7
- Affected
- Maven org.apache.camel:camel-snakeyaml < 2.17.5; >= 2.18.0, < 2.18.2
- Fixed in
- 2.17.52.18.2· Vendor fix available
- Issue
- Apache Camel's camel-snakeyaml component is vulnerable to Java object de-serialization. De-serializing untrusted data can lead to security flaws.
Recommended action: Upgrade to 2.18.2 or 2.17.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.