Critical, CVSS 9.8MavenPublished
Deserialization of Untrusted Data in Apache Camel RabbitMQ
CVE-2020-11972 · GHSA-2x6r-7427-95cm
- Affected
- Maven org.apache.camel:camel-rabbitmq < 2.25.1; >= 3.0.0, < 3.2.0
- Fixed in
- 3.2.02.25.1· Vendor fix available
- Issue
- Apache Camel RabbitMQ enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.
Recommended action: Upgrade to 3.2.0 or 2.25.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.