Critical, CVSS 9.8MavenPublished
camel-ldap component allows LDAP Injection when using the filter option
CVE-2022-45046 · GHSA-w66j-xc7r-m2jv
- Affected
- Maven org.apache.camel:camel-ldap < 3.14.6; >= 3.15.0, < 3.18.4
- Fixed in
- 3.14.63.18.4· Vendor fix available
- Issue
- The camel-ldap component allows LDAP Injection when using the filter option. Users are recommended to either move to the Camel-Spring-Ldap component (which is not affected) or upgrade to 3.14.6 or 3.18.4.
Recommended action: Upgrade to 3.18.4 or 3.14.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.