High, CVSS 7.3MavenPublished
Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters
CVE-2026-49042 · GHSA-hh8r-75r6-qrg9
- Affected
- Maven org.apache.camel:camel-langchain4j-agent >= 4.8.0, < 4.18.3; >= 4.19.0, < 4.21.0
- Fixed in
- 4.21.04.18.3· Vendor fix available
- Issue
- Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Recommended action: Upgrade to 4.21.0 or 4.18.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.