Critical, CVSS 9.8MavenPublished
Camel-castor component in Apache Camel is vulnerable to Java object de-serialisation
CVE-2017-12634 · GHSA-vf4q-8mr7-5c5c
- Affected
- Maven org.apache.camel:camel-castor >= 2.0.0, < 2.19.4; >= 2.20.0, <= 2.20.0
- Fixed in
- 2.20.12.19.4· Vendor fix available
- Issue
- The camel-castor component in Apache Camel 2.x before 2.19.4 and 2.20.x before 2.20.1 is vulnerable to Java object de-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.
Recommended action: Upgrade to 2.20.1 or 2.19.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.