Skip to content

← Public intelligence

Maven package

org.apache.bookkeeper:bookkeeper-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9MavenAmendedPublished

    Apache Bookkeeper vulnerable to Improper Certificate Validation

    CVE-2022-32531 · GHSA-gxq5-79m2-gvvq

    Affected
    • Maven org.apache.bookkeeper:bookkeeper-common < 4.14.6; >= 4.15.0, <= 4.15.0
    Fixed in
    4.15.14.14.6· Vendor fix available
    Issue
    The Apache Bookkeeper Java Client (before 4.14.6 and also 4.15.0) does not close the connection to the bookkeeper server when TLS hostname verification fails. This leaves the bookkeeper client vulnerable to a man in the middle attack. The problem affects BookKeeper client prior to versions 4.14.6 and 4.15.1.

    Recommended action: Upgrade to 4.15.1 or 4.14.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →