Skip to content

← Public intelligence

Maven package

org.apache.axis2:axis2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Axis2 Vulnerable to XML Signature wrapping attack

    CVE-2012-4418 · GHSA-88r4-38gc-97p4

    Affected
    • Maven org.apache.axis2:axis2 < 1.7.9
    Fixed in
    1.7.9· Vendor fix available
    Issue
    Apache Axis2 allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."

    Recommended action: Upgrade to 1.7.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Apache Axis2 has Improper Input Validation

    CVE-2012-5785 · GHSA-wwq7-pxwc-p4rc

    Affected
    • Maven org.apache.axis2:axis2 < 1.8.0
    Fixed in
    1.8.0· Vendor fix available
    Issue
    Apache Axis2/Java 1.7.9 and earlier does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

    Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Improper Authentication in Apache Axis2

    CVE-2012-5351 · GHSA-66rx-gqx3-p98m

    Affected
    • Maven org.apache.axis2:axis2 < 1.6.4
    Fixed in
    1.6.4· Vendor fix available
    Issue
    Apache Axis2 allows remote attackers to forge messages and bypass authentication via a SAML assertion that lacks a Signature element, aka a "Signature exclusion attack," a different vulnerability than CVE-2012-4418.

    Recommended action: Upgrade to 1.6.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →