Medium, CVSS 5.3MavenPublished
Apache Axis allows Exposure of Sensitive Information to an Unauthorized Actor
CVE-2007-2353 · GHSA-2c4w-2px5-9x3x
- Affected
- Maven org.apache.axis:axis < 1.2
- Fixed in
- 1.2· Vendor fix available
- Issue
- Apache Axis 1.0 allows remote attackers to obtain sensitive information by requesting a non-existent WSDL file, which reveals the installation path in the resulting exception message.
Recommended action: Upgrade to 1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.