Skip to content

← Public intelligence

Maven package

org.apache.ant:ant

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5MavenPublished

    Improper Handling of Length Parameter Inconsistency in Apache Ant

    CVE-2021-36374 · GHSA-5v34-g2px-j4fw

    Affected
    • Maven org.apache.ant:ant >= 1.10.0, < 1.10.11; >= 1.9.0, < 1.9.16
    Fixed in
    1.10.111.9.16· Vendor fix available
    Issue
    When reading a specially crafted ZIP archive, or a derived formats, an Apache Ant build can be made to allocate large amounts of memory that leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Commonly used derived formats from ZIP archives are for instance JAR files and many office files. Apache Ant prior to 1.9.16 and 1.10.11 were affected.

    Recommended action: Upgrade to 1.10.11 or 1.9.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.5MavenPublished

    Improper Handling of Length Parameter Inconsistency in Apache Ant

    CVE-2021-36373 · GHSA-q5r4-cfpx-h6fh

    Affected
    • Maven org.apache.ant:ant < 1.9.16; >= 1.10.0, < 1.10.11
    Fixed in
    1.10.111.9.16· Vendor fix available
    Issue
    When reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Apache Ant prior to 1.9.16 and 1.10.11 were affected.

    Recommended action: Upgrade to 1.10.11 or 1.9.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Code injection in Apache Ant

    CVE-2020-11979 · GHSA-f62v-xpxf-3v68

    Affected
    • Maven org.apache.ant:ant < 1.10.9
    Fixed in
    1.10.9· Vendor fix available
    Issue
    As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so that only the current user was allowed to access them. Unfortunately the fixcrlf task deleted the temporary file and created a new one without said protection, effectively nullifying the effort. This would still allow an attacker to inject modified source files into the build process.

    Recommended action: Upgrade to 1.10.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.3MavenPublished

    Sensitive Data Exposure in Apache Ant

    CVE-2020-1945 · GHSA-4p6w-m9wc-c9c9

    Affected
    • Maven org.apache.ant:ant >= 1.1, < 1.9.15; >= 1.10.0, < 1.10.8
    Fixed in
    1.10.81.9.15· Vendor fix available
    Issue
    Apache Ant 1.1 to 1.9.14 and 1.10.0 to 1.10.7 uses the default temporary directory identified by the Java system property java.io.tmpdir for several tasks and may thus leak sensitive information. The fixcrlf and replaceregexp tasks also copy files from the temporary directory back into the build tree allowing an attacker to inject modified source files into the build process.

    Recommended action: Upgrade to 1.10.8 or 1.9.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →