Skip to content

← Public intelligence

Maven package

org.apache.accumulo:accumulo-master

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Improper privilege handling in Apache Accumulo

    CVE-2020-17533 · GHSA-grc3-8q8m-4j7c

    Affected
    • Maven org.apache.accumulo:accumulo-master >= 1.5.0, < 1.10.1; >= 2.0.0, <= 2.0.0
    Fixed in
    2.0.11.10.1· Vendor fix available
    Issue
    Apache Accumulo versions 1.5.0 through 1.10.0 and version 2.0.0 do not properly check the return value of some policy enforcement functions before permitting an authenticated user to perform certain administrative operations. Specifically, the return values of the 'canFlush' and 'canPerformSystemActions' security functions are not checked in some instances, therefore allowing an authenticated user with insufficient permissions to perform the following actions: flushing a table, shutting down Accumulo or an individual tablet server, and setting or removing system-wide Accumulo configuration properties.

    Recommended action: Upgrade to 2.0.1 or 1.10.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →