High, CVSS 8.6MavenPublished
Yauaa vulnerable to ArrayIndexOutOfBoundsException triggered by a crafted Sec-Ch-Ua-Full-Version-List
CVE-2022-23496 · GHSA-c4pm-63cg-9j7h
- Affected
- Maven nl.basjes.parse.useragent:yauaa-flink-table >= 7.0.0, < 7.9.0
- Fixed in
- 7.9.0· Vendor fix available
- Issue
- Impact Applications using the Client Hints analysis feature introduced with 7.0.0 can crash because the Yauaa library throws an ArrayIndexOutOfBoundsException. Applications that do not use this feature are not affected. Patches Upgrade to 7.9.0 Workarounds Catch and discard any exceptions from Yauaa.
Recommended action: Upgrade to 7.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.