Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Impact NekoHtml Parser suffers from a denial of service vulnerability on versions 2.60.0 and below. A specifically crafted input regarding the parsing of processing instructions leads to heap memory consumption. Please update to version 2.61.0. For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/HtmlUnit/htmlunit-neko Email us at [rbri at rbri.de]
Recommended action: Upgrade to 2.61.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
Recommended action: Upgrade to 2.27 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.