High, CVSS 8.0MavenPublished
Stored XSS vulnerability in computer-queue-plugin Plugin
CVE-2020-2259 · GHSA-qg66-xv7v-m834
- Affected
- Maven jenkins.ci.plugins.computerqueue:computer-queue-plugin <= 1.5
- Fixed in
- 1.6· Vendor fix available
- Issue
- computer-queue-plugin Plugin 1.5 and earlier does not escape the agent name in tooltips. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission. computer-queue-plugin Plugin 1.6 escapes the agent name in tooltips.
Recommended action: Upgrade to 1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.