High, CVSS 7.5MavenPublished
Information Exposure in Netty
CVE-2015-2156 · GHSA-xfv3-rrfm-f2rv
- Affected
- Maven io.netty:netty-parent >= 4.0.0, < 4.0.28.Final
- Fixed in
- 4.0.28.Final· Vendor fix available
- Issue
- Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.
Recommended action: Upgrade to 4.0.28.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.