Medium, CVSS 6.1MavenPublished
XSS vulnerability in Jenkins TICS Plugin
CVE-2021-21613 · GHSA-xmw5-45v9-pxqx
- Affected
- Maven io.jenkins.plugins:tics <= 2020.3.0.6
- Fixed in
- 2020.3.0.7· Vendor fix available
- Issue
- Jenkins TICS Plugin 2020.3.0.6 and earlier does not escape TICS service responses. This results in a cross-site scripting (XSS) vulnerability exploitable by attackers able to control TICS service response content. Jenkins TICS Plugin 2020.3.0.7 escapes TICS service responses, or strips HTML out, as appropriate.
Recommended action: Upgrade to 2020.3.0.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.