Skip to content

← Public intelligence

Maven package

io.jenkins.plugins:pipeline-groovy-lib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins Pipeline: Groovy Plugin vulnerable to unrestricted instantiation of types

    CVE-2026-57284 · GHSA-2w2h-gwwj-fh3q

    Affected
    • Maven io.jenkins.plugins:pipeline-groovy-lib < 4331.4333
    Fixed in
    4331.4333· Vendor fix available
    Issue
    Jenkins Pipeline: Groovy Plugin 4331.v9d06ed4658ff and earlier does not restrict the types that can be instantiated through the Pipeline Snippet Generator, instantiating any type with a constructor annotated with @DataBoundConstructor in response to a request. This allows attackers to have Pipeline: Groovy Plugin instantiate types related to job or system configuration other than Pipeline steps. Additionally, this HTTP endpoint can be accessed using the GET method and does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. This allows attackers to create a script approval request attributed to another user, impersonating a trusted user when social engineering an administrator into approving a malicious script. This vulnerability has been reported through the Jenkins Bug Bounty Program sponsored by the European Commission. Pipeline: Groovy Plugin 4331.4333.v50ab076c5199 only instantiates Pipeline steps and metastep delegates through the Snippet…

    Recommended action: Upgrade to 4331.4333 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Jenkins Pipeline: Groovy Plugin has a CSRF vulnerability

    CVE-2026-57283 · GHSA-72c8-3wwg-r59w

    Affected
    • Maven io.jenkins.plugins:pipeline-groovy-lib < 4331.4333
    Fixed in
    4331.4333· Vendor fix available
    Issue
    Jenkins Pipeline: Groovy Plugin 4331.v9d06ed4658ff and earlier does not restrict the types that can be instantiated through the Pipeline Snippet Generator, instantiating any type with a constructor annotated with @DataBoundConstructor in response to a request. This allows attackers to have Pipeline: Groovy Plugin instantiate types related to job or system configuration other than Pipeline steps. Additionally, this HTTP endpoint can be accessed using the GET method and does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. This allows attackers to create a script approval request attributed to another user, impersonating a trusted user when social engineering an administrator into approving a malicious script. This vulnerability has been reported through the Jenkins Bug Bounty Program sponsored by the European Commission. Pipeline: Groovy Plugin 4331.4333.v50ab076c5199 only instantiates Pipeline steps and metastep delegates through the Snippet…

    Recommended action: Upgrade to 4331.4333 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    Jenkins Pipeline: Groovy Libraries Plugin does not prohibit symbolic links in shared libraries

    CVE-2026-48921 · GHSA-qjq3-wqj5-g37q

    Affected
    • Maven io.jenkins.plugins:pipeline-groovy-lib < 798.v5cc688825312
    Fixed in
    798.v5cc688825312· Vendor fix available
    Issue
    Jenkins Pipeline: Groovy Libraries Plugin 797.v90eaa9be45a0 and earlier does not prohibit symbolic links in shared libraries. This allows attackers able to control the content of a library used by a Pipeline job to read arbitrary files on the Jenkins controller filesystem. Pipeline: Groovy Libraries Plugin 798.v5cc688825312 prohibits symbolic links in shared libraries.

    Recommended action: Upgrade to 798.v5cc688825312 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →