Medium, CVSS 5.4MavenPublished
XSS vulnerability in Jenkins Markdown Formatter Plugin
CVE-2021-21660 · GHSA-xqpp-26pp-2365
- Affected
- Maven io.jenkins.plugins:markdown-formatter <= 0.1.0
- Fixed in
- 0.2.0· Vendor fix available
- Issue
- Jenkins Markdown Formatter Plugin 0.1.0 and earlier uses a Markdown library to parse Markdown that does not escape crafted link target URLs. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with the ability to edit any description rendered using the configured markup formatter. Jenkins Markdown Formatter Plugin 0.2.0 uses a different Markdown library that is not affected by this problem.
Recommended action: Upgrade to 0.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.