Medium, CVSS 6.8MavenPublished
Stored Cross-site Scripting in folder-auth plugin
CVE-2022-27200 · GHSA-5vjc-qx43-r747
- Affected
- Maven io.jenkins.plugins:folder-auth < 1.4
- Fixed in
- 1.4· Vendor fix available
- Issue
- Folder-based Authorization Strategy Plugin 1.3 and earlier does not escape the names of roles shown on the configuration form. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission. Folder-based Authorization Strategy Plugin 1.4 escapes the names of roles shown on the configuration form. See https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2646
Recommended action: Upgrade to 1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.