High, CVSS 8.0MavenPublished
Jenkins Coverage Plugin has a stored cross-site scripting (XSS) vulnerability
CVE-2025-67641 · GHSA-v3f3-rf6r-43x5
- Affected
- Maven io.jenkins.plugins:coverage < 2.3056
- Fixed in
- 2.3056· Vendor fix available
- Issue
- Jenkins Coverage Plugin 2.3054.ve1ff7baa123b and earlier does not validate the configured coverage results ID when creating coverage results, only when submitting the job configuration through the UI, allowing attackers with Item/Configure permission to use a javascript: scheme URL as identifier by configuring the job through the REST API, resulting in a stored cross-site scripting (XSS) vulnerability.
Recommended action: Upgrade to 2.3056 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.